Phone Support Service Disruption

Incident Report for HungerRush

Resolved

This incident has been resolved.
Posted May 13, 2026 - 13:53 CDT

Update

We are currently experiencing an issue impacting our phone support system through Zendesk Talk. Customers may experience difficulty reaching Support by phone, longer hold times, or disconnected calls.
Zendesk has confirmed an outage affecting our service pod, and their engineering teams are actively working toward resolution.
We apologize for the inconvenience and will provide updates as more information becomes available.
Posted May 13, 2026 - 12:57 CDT

Identified

We are currently experiencing an issue impacting our phone support system through Zendesk Talk. Customers may experience difficulty reaching Support by phone, longer hold times, or disconnected calls.
Zendesk has confirmed an outage affecting our service pod, and their engineering teams are actively working toward resolution.
We apologize for the inconvenience and will provide updates as more information becomes available.
Posted May 13, 2026 - 12:35 CDT
This incident affected: Customer Support (Phone).