World Pay Credit Card Processing
Incident Report for HungerRush
Resolved
We're pleased to confirm that Worldpay has resolved the issues affecting credit card transactions. As of now, all services are fully restored, though some businesses may experience intermittent errors during the final stages of implementation.

Thank you for your patience and cooperation throughout this process. Should you have any questions, please contact our customer support team at 281-971-2500.

Thank you for your cooperation during this time.
Posted Jan 27, 2024 - 11:19 CST
Monitoring
We are pleased to inform you that World Pay has advised us that the issues impacting credit card transactions on their platform have been essentially resolved.

They are actively working to ensure that all services are fully restored as quickly as possible.

Please note that some businesses might still experience intermittent errors as the resolution is fully implemented.

We appreciate your patience and understanding as we continue to monitor the situation.
We will keep you informed of any further developments.

Thank you for your cooperation during this time.
Posted Jan 27, 2024 - 00:26 CST
Update
We are aware of ongoing issues with credit card transactions on the World Pay Integrated Payments Platform.

We're actively working with World Pay to resolve this. Official details have not been provided, our contact indicates they're aware of an outage.

We'll keep you updated as we learn more. Thank you for your patience.
Posted Jan 26, 2024 - 21:09 CST
Investigating
There is an outage affecting Credit Card processing with World Pay.

We are working with our partners to investigate the issue and will continue to provide updates.
Posted Jan 26, 2024 - 19:22 CST
This incident affected: Payment Processing (WorldPay Express (heritage Revention), WorldPay Integrated Payments (heritage CRS)).