HR360 Login Failures
Incident Report for HungerRush
Resolved
We have applied the fix to the HR360 issue causing login problems. All HR360 customers should be able to login and function normally.
Posted Apr 13, 2023 - 09:12 CDT
Identified
Customers on our HR360 Platform have reported issues logging into the system. We identified the issue and will have a fix applied within the next 30 minutes. We will post updates shortly.
Posted Apr 13, 2023 - 08:52 CDT
This incident affected: Management Console.