WorldPay Outage

Incident Report for HungerRush

Resolved

This incident has been resolved. Payment processing in the POS has been restored.
Posted Sep 18, 2026 - 18:50 CDT

Investigating

We are currently investigating an issue with credit card processing payments on WorldPay.
Posted Sep 18, 2026 - 17:14 CDT
This incident affected: Payment Processing (WorldPay Express (heritage Revention), WorldPay Integrated Payments (heritage CRS), WorldPay Core).