OrderAI Support Line Maintenance

Incident Report for HungerRush

Resolved

Support lines are operational.
Posted Jul 02, 2025 - 12:05 CDT

Identified

Our OrderAI support phone line is experiencing a brief planned outage today from 11:30 AM to 1:00 PM EST due to carrier maintenance.
During this time, please reach us by email at support@orderai.com or contact your dedicated account representative for any urgent concerns. Service is expected to be fully restored by 1:00 PM EST.
Posted Jul 02, 2025 - 10:28 CDT
This incident affected: Customer Support (Phone).