Support Phone System Is Degraded - Wait Times are Long
Incident Report for HungerRush
Resolved
This issue has been resolved.
Posted Jun 15, 2023 - 20:22 CDT
Monitoring
Our phone provider has implemented a fix to the issue. We are monitoring the situation to ensure everything is back to normal.

If you have an issue that is not urgent, please use this link to our web form to create a new ticket:
https://support.hungerrush.com/hc/en-us/requests/new
Posted Jun 15, 2023 - 18:44 CDT
Update
Our phone provider is having issues with their service at this time. As a result, connecting with an agent is taking an exceptionally long time.

If you are able to open a ticket via a web form, please go to this link to log your ticket:
https://support.hungerrush.com/hc/en-us/requests/new

Logging an issue this way will automatically open a ticket in our work queue to be picked up by our Agents.

We will update status of this issue by 6:00 PM CDT.
Posted Jun 15, 2023 - 18:34 CDT
Update
Our provider is still researching the issue. Queues remain high.

Please use the web form, especially for non-urgent issues:
https://support.hungerrush.com/hc/en-us/requests/new

We will update again at 6:30 PM CDT
Posted Jun 15, 2023 - 18:04 CDT
Investigating
Our phone provider is having issues with their service at this time. As a result, connecting with an agent is taking an exceptionally long time.

If you are able to open a ticket via a web form, please go to this link to log your ticket:
https://support.hungerrush.com/hc/en-us/requests/new

Logging an issue this way will automatically open a ticket in our work queue to be picked up by our Agents.

We will update status of this issue by 6:00 PM CDT.
Posted Jun 15, 2023 - 17:27 CDT
This incident affected: Customer Support (Phone).