Phone services have been fully restored and are operating normally. Agents are able to assist, and calls are routing successfully.
No further impact has been observed, and the issue is now considered resolved.
We appreciate your patience while we worked through this disruption.
Posted Oct 20, 2025 - 21:24 CDT
Monitoring
Phone Support Services are currently operational, and calls are connecting successfully.
We continue to monitor system performance as stability improves following earlier disruptions related to our upstream provider.
Customers may continue to reach Support through phone or the Support Portal at Support.HungerRush.com.
Posted Oct 20, 2025 - 10:19 CDT
Update
Phone services are beginning to recover, and inbound calls are connecting successfully. We are continuing to monitor system stability as our providers complete recovery efforts.
Thank you for your patience while we confirm full restoration.
Customers can continue to reach Support through ticket submission via the Support Portal at Support.HungerRush.com
Posted Oct 20, 2025 - 07:36 CDT
Identified
We are currently experiencing an outage impacting our phone system due to an ongoing service disruption with our providers. While the IVR is operational, callers may hear a message indicating that no agents are available or experience long call queue times.
Customers can continue to reach Support through ticket submission via the Support Portal at Support.HungerRush.com
We will provide updates here as soon as more information is available.