HungerRush Credit Card Readers

Incident Report for HungerRush

Resolved

The issue affecting some Verifone credit card readers has been resolved.

Datacap has confirmed the issue was caused by a recent Windows update that affected Verifone device drivers. Some systems displayed errors such as “Datacap Configuration Not Found or Incorrect” or “Transaction Not Complete - NAK error from PIN Pad.”

Functionality has been restored, and no further incidents have been reported.

All systems are operating normally, and this incident is now considered resolved.
Posted Oct 22, 2025 - 10:05 CDT

Identified

We have confirmed an issue affecting Verifone credit card readers following a recent Windows update. Some locations may see errors such as “Datacap Configuration Not Found or Incorrect” or “Transaction Not Complete - NAK error from PIN Pad.”

Our teams are working closely with partners to restore normal processing. In many cases, restarting the reader may provide a fix.

If your card readers remain offline or display errors, please contact HungerRush Support for assistance.

We will continue to provide updates as more information becomes available.
Posted Oct 21, 2025 - 09:57 CDT

Update

We are currently investigating reports of credit card readers not processing transactions. This may prevent some customers from completing payments at the point of sale.

Initial findings indicate that restarting the card reader resolves the issue in many cases, though some locations may require additional troubleshooting.

Our teams are actively investigating the cause and working to ensure a full and stable resolution.
Posted Oct 20, 2025 - 11:50 CDT

Investigating

We are currently investigating reports of credit card readers not processing transactions. This may prevent some customers from completing payments at the point of sale.

Initial findings indicate that restarting the card reader resolves the issue in many cases, though some locations may require additional troubleshooting.

Our teams are actively investigating the cause and working to ensure a full and stable resolution.
Posted Oct 20, 2025 - 11:50 CDT
This incident affected: Payment Processing (WorldPay Express (heritage Revention), WorldPay Integrated Payments (heritage CRS)) and HungerRush POS Hardware.