Possible Inbound Phone Issue
Incident Report for HungerRush
Resolved
In collaboration with our partners, we've successfully pinpointed and addressed an issue that could have led to disconnections during periods of high call volume.

If you encounter any difficulties connecting to our inbound line, please attempt your call once more. Alternatively, you can reach out to us through our alternative support numbers: (281) 612-8964, (281) 971-2500, or 877-738-7444. You may also submit a support ticket by visiting: https://support.hungerrush.com/hc/en-us/requests.
Posted Nov 21, 2023 - 16:29 CST
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Nov 13, 2023 - 08:06 CST
Update
We are continuing to work with our partners to identify the cause of any potential issues with our inbound phone line.
If your call does not go through to our inbound line, please try calling again, reaching us using one of our alternative support numbers (281) 612-8964, (281)-971-2500, or 877-738-7444, or submitting a ticket here: https://support.hungerrush.com/hc/en-us/requests.
Posted Nov 10, 2023 - 17:47 CST
Investigating
We are currently investigating a potential issue with our inbound phone line. If your call does not go through to our inbound line, please try calling again, reaching us using one of our alternative support numbers (281) 612-8964, (281)-971-2500, or 877-738-7444, or submitting a ticket here: https://support.hungerrush.com/hc/en-us/requests.
Posted Nov 10, 2023 - 14:33 CST
This incident affected: Customer Support (Phone).